Martin Polednik has posted comments on this change.

Change subject: supervdsm: only trigger 'vfio' subsystem for VFIO devices
......................................................................


Patch Set 5:

(1 comment)

https://gerrit.ovirt.org/#/c/45345/5/vdsm/supervdsmServer
File vdsm/supervdsmServer:

Line 313:         try:
Line 314:             udevadm.trigger(subsystem_matches=('vfio',))
Line 315:         except udevadm.Error as e:
Line 316:             raise OSError(errno.EINVAL, 'Could not trigger change '
Line 317:                           'out %s\nerr %s' % (e.out, e.err))
> AFAIU Nir sees this an helper function, so he wants to see this nearby the 
It is possible, but tricky: we want to keep the new methods module-private, 
therefore at least this part of split would have to be done. Then, in future we 
have udevTriggerUSB coming where only the arguments are different - that could 
be handled by a map. Question is - is _udevTrigger([USB/VFIO], args=...) or 
equivalent better (more readable) then _udevTriggerUSB(bus, device) and 
_udevTriggerVFIO(iommu_group)?
Line 318: 
Line 319:     @logDecorator
Line 320:     def appropriateMultipathDevice(self, guid, thiefId):
Line 321:         ruleFile = _UDEV_RULE_FILE_NAME % (guid, thiefId)


-- 
To view, visit https://gerrit.ovirt.org/45345
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Icb4fecbe5108a6ff7d695887e6e60df36e4874d7
Gerrit-PatchSet: 5
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Martin Polednik <mpoled...@redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <dan...@redhat.com>
Gerrit-Reviewer: Francesco Romani <from...@redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Martin Polednik <mpoled...@redhat.com>
Gerrit-Reviewer: Nir Soffer <nsof...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-HasComments: Yes
_______________________________________________
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches

Reply via email to