Adam Litke has uploaded a new change for review.

Change subject: schema: Eliminate 'class' from StorageDomainInfo
......................................................................

schema: Eliminate 'class' from StorageDomainInfo

'class' is usually a reserved word and makes a bad name for a type field.
Change it to domainClass and add the required type fixup to the Bridge.

Change-Id: I7d13d4c6141e42c996b50a86d4b812c8c42f831f
Signed-off-by: Adam Litke <a...@us.ibm.com>
---
M vdsm_api/Bridge.py
M vdsm_api/vdsmapi-schema.json
2 files changed, 12 insertions(+), 11 deletions(-)


  git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/11/11711/1

diff --git a/vdsm_api/Bridge.py b/vdsm_api/Bridge.py
index 49b1558..8fade0f 100644
--- a/vdsm_api/Bridge.py
+++ b/vdsm_api/Bridge.py
@@ -371,4 +371,5 @@
     'IscsiCredentials': partial(fieldClone, 'type', 'authType'),
     'ConnectionRefArgs': partial(fieldClone, 'type', 'connType'),
     'VolumeInfo': partial(fieldClone, 'type', 'allocType'),
+    'StorageDomainInfo': partial(fieldClone, 'class', 'domainClass'),
 }
diff --git a/vdsm_api/vdsmapi-schema.json b/vdsm_api/vdsmapi-schema.json
index b4eb825..a83a799 100644
--- a/vdsm_api/vdsmapi-schema.json
+++ b/vdsm_api/vdsmapi-schema.json
@@ -3543,31 +3543,31 @@
 #
 # Information about a Storage Domain.
 #
-# @uuid:        The Storage Domain UUID
+# @uuid:         The Storage Domain UUID
 #
-# @domainType:  The type of backing storage used by this domain
+# @domainType:   The type of backing storage used by this domain
 #
-# @class:       The Storage Domain class
+# @domainClass:  The Storage Domain class
 #
-# @name:        The human-readable name for this Storage Domain
+# @name:         The human-readable name for this Storage Domain
 #
-# @role:        The Storage Domain role
+# @role:         The Storage Domain role
 #
-# @pool:        The Storage Pool associated with this Storage Domain
+# @pool:         The Storage Pool associated with this Storage Domain
 #
-# @version:     The version of this Storage Domain
+# @version:      The version of this Storage Domain
 #
-# @lver:        The lock version of the associated Storage Pool
+# @lver:         The lock version of the associated Storage Pool
 #
-# @spm_id:      Contains the Host ID of the Storage Pool Manager
+# @spm_id:       Contains the Host ID of the Storage Pool Manager
 #
-# @master_ver:  The version of the master Storage Domain
+# @master_ver:   The version of the master Storage Domain
 #
 # Since: 4.10.0
 ##
 {'type': 'StorageDomainInfo',
  'data': {'uuid': 'UUID', 'domainType': 'StorageDomainType',
-          'class': 'StorageDomainImageClass', 'name': 'str',
+          'domainClass': 'StorageDomainImageClass', 'name': 'str',
           'role': 'StorageDomainRole', 'pool': ['UUID'], 'version': 'int',
           'lver': 'int', 'spm_id': 'int', 'master_ver': 'int'}}
 


--
To view, visit http://gerrit.ovirt.org/11711
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I7d13d4c6141e42c996b50a86d4b812c8c42f831f
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke <a...@us.ibm.com>
_______________________________________________
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches

Reply via email to