Martin Polednik has uploaded a new change for review.

Change subject: devices: rename VideoDevice to Device
......................................................................

devices: rename VideoDevice to Device

No functionality changes, only naming naming changes

Change-Id: I4f33a6862a071749512b2a8613451fe319ffbd13
Signed-off-by: Martin Polednik <mpoled...@redhat.com>
---
M tests/vmTests.py
M vdsm/virt/vm.py
M vdsm/virt/vmdevices.py
3 files changed, 3 insertions(+), 3 deletions(-)


  git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/91/34391/1

diff --git a/tests/vmTests.py b/tests/vmTests.py
index b29cd84..c73db76 100644
--- a/tests/vmTests.py
+++ b/tests/vmTests.py
@@ -538,7 +538,7 @@
 
         dev = {'device': 'vga', 'specParams': {'vram': '32768',
                'heads': '2'}}
-        video = vmdevices.VideoDevice(self.conf, self.log, **dev)
+        video = vmdevices.Video(self.conf, self.log, **dev)
         self.assertXML(video.getXML(), videoXML)
 
     def testInterfaceXML(self):
diff --git a/vdsm/virt/vm.py b/vdsm/virt/vm.py
index 634b3b5..5b5e155 100644
--- a/vdsm/virt/vm.py
+++ b/vdsm/virt/vm.py
@@ -1363,7 +1363,7 @@
     DeviceMapping = ((DISK_DEVICES, Drive),
                      (NIC_DEVICES, NetworkInterfaceDevice),
                      (SOUND_DEVICES, SoundDevice),
-                     (VIDEO_DEVICES, vmdevices.VideoDevice),
+                     (VIDEO_DEVICES, vmdevices.Video),
                      (GRAPHICS_DEVICES, GraphicsDevice),
                      (CONTROLLER_DEVICES, ControllerDevice),
                      (GENERAL_DEVICES, vmdevices.Generic),
diff --git a/vdsm/virt/vmdevices.py b/vdsm/virt/vmdevices.py
index ab07d18..a047a6b 100644
--- a/vdsm/virt/vmdevices.py
+++ b/vdsm/virt/vmdevices.py
@@ -54,7 +54,7 @@
         return self.createXmlElem(self.type, self.device, ['address'])
 
 
-class VideoDevice(Base):
+class Device(Base):
     __slots__ = ('address',)
 
     def getXML(self):


-- 
To view, visit http://gerrit.ovirt.org/34391
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I4f33a6862a071749512b2a8613451fe319ffbd13
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Martin Polednik <mpoled...@redhat.com>
_______________________________________________
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches

Reply via email to