On 4/22/2018 10:06 AM, Michael S. Tsirkin wrote:
On Thu, Apr 19, 2018 at 06:42:02PM -0700, Sridhar Samudrala wrote:
+#if IS_ENABLED(CONFIG_NET_FAILOVER)
+
+int failover_create(struct net_device *standby_dev,
+ struct failover **pfailover);
Should we rename all these structs net_failover?
It's possible to extend the concept to storage I think.
We could, the only downside is that the names become longer. i think we need
to change the filenames and the function names also to be consistent.
+void failover_destroy(struct failover *failover);
+
+int failover_register(struct net_device *standby_dev, struct failover_ops *ops,
+ struct failover **pfailover);
+void failover_unregister(struct failover *failover);
+
+int failover_slave_unregister(struct net_device *slave_dev);
+
+#else
+
+static inline
+int failover_create(struct net_device *standby_dev,
+ struct failover **pfailover);
+{
+ return 0;
Does this make callers do something sane?
Shouldn't these return an error?
Yes. i think i should return -EOPNOTSUPP here, so that we fail
when CONFIG_NET_FAILOVER is not enabled and the virtio-net driver is trying
to create a failover device.
+}
+
+static inline
+void failover_destroy(struct failover *failover)
+{
+}
+
+static inline
+int failover_register(struct net_device *standby_dev, struct failover_ops *ops,
+ struct pfailover **pfailover);
+{
+ return 0;
+}
struct pfailover seems like a typo.
yes. will also change the return to -EOPNOTSUPP
+
+static inline
+void failover_unregister(struct failover *failover)
+{
+}
+
+static inline
+int failover_slave_unregister(struct net_device *slave_dev)
+{
+ return 0;
+}
Does anyone test return value of unregister?
should this be void?
yes. can be changed to void.
+
+#endif
+
+#endif /* _NET_FAILOVER_H */
---------------------------------------------------------------------
To unsubscribe, e-mail: virtio-dev-unsubscr...@lists.oasis-open.org
For additional commands, e-mail: virtio-dev-h...@lists.oasis-open.org