On Thu, 26 Feb 2004, Herbert Poetzl wrote:
> we had a long discussion on irc, and agreed on the
> current interface (don't you remember?)

I recall stating that I would not write any userspace program against your
broken interface until you until you fixed/reverted it.

I am unlikely to have to have done that if I was in agreement.

> "reboot restart"      instead of      "restart"
> [is] superior to the other?

It is not superior.  The following is the original and is superior.

  "sys_reboot" "restart"
  "sys_reboot" "halt"
  "sys_reboot" "poweroff"

Notice the two separate springs.  One is the function() and one is the
parameter.  This is the prototype for the system call `reboot(2)':

         int reboot (int flag);

One is a function() and one is a parameter.  They match.

In your design you've chosen to discard the most important detail;  the name
of the function !  Let wrap some others calls for context 42:

bdflush(sub_function, pointer)

  Good:  vshelper "42" "sys_bdflush" "1" "pointer"
  Bad:   vshelper "1" "pointer" "42"

sync():

  Good:  vshelper "42" "sys_sync"
  Bad:   vshelper "42"

What I /did/ agree to was you droping the `sys_' off the front.

        -Paul
-- 
Is there no safe way to travel?  London, GB




_______________________________________________
Vserver mailing list
[EMAIL PROTECTED]
http://list.linux-vserver.org/mailman/listinfo/vserver

Reply via email to