I am trying to standardize my naming schemes for my database, table and 
fields. I am trying to follow the one given below. Please share with me your 
scheme.

Standard Database Table Naming Scheme
=====================================
Table name:
-----------
small caps with underscore
look-up table prefixed with 'lu_'
link table prefixed with 'lk_' (should i do this?)

eg.
contact
lu_address_type


Field names:
------------
small caps with under score
primary key suffixed with '_id'

eg.
name
address_text
contact_id

Table Field access notation:
---------------------------
table name DOT field name

eg.
contact.name
contact.contact_id
lu_address_type.name
lu_address_type.address_type

Reply via email to