Title: [201181] trunk/LayoutTests
Revision
201181
Author
bb...@apple.com
Date
2016-05-19 14:11:02 -0700 (Thu, 19 May 2016)

Log Message

Web Inspector: use a consistent prefix for injected scripts
https://bugs.webkit.org/show_bug.cgi?id=157715
<rdar://problem/26287188>

Reviewed by Alexey Proskuryakov.

Follow-up fix to an affected test.

* inspector/debugger/scriptParsed.html:
Check whether the script is for CommandLineAPIModuleSource before
checking whether it is an InjectedScript. With the new naming scheme,
the latter is a subset of the former, so do the more specific check first.

Modified Paths

Diff

Modified: trunk/LayoutTests/ChangeLog (201180 => 201181)


--- trunk/LayoutTests/ChangeLog	2016-05-19 21:02:44 UTC (rev 201180)
+++ trunk/LayoutTests/ChangeLog	2016-05-19 21:11:02 UTC (rev 201181)
@@ -4,6 +4,21 @@
         https://bugs.webkit.org/show_bug.cgi?id=157715
         <rdar://problem/26287188>
 
+        Reviewed by Alexey Proskuryakov.
+
+        Follow-up fix to an affected test.
+
+        * inspector/debugger/scriptParsed.html:
+        Check whether the script is for CommandLineAPIModuleSource before
+        checking whether it is an InjectedScript. With the new naming scheme,
+        the latter is a subset of the former, so do the more specific check first.
+
+2016-05-19  Brian Burg  <bb...@apple.com>
+
+        Web Inspector: use a consistent prefix for injected scripts
+        https://bugs.webkit.org/show_bug.cgi?id=157715
+        <rdar://problem/26287188>
+
         Reviewed by Timothy Hatcher.
 
         Update how inspector tests check sourceURLs for internal scripts.

Modified: trunk/LayoutTests/inspector/debugger/scriptParsed.html (201180 => 201181)


--- trunk/LayoutTests/inspector/debugger/scriptParsed.html	2016-05-19 21:02:44 UTC (rev 201180)
+++ trunk/LayoutTests/inspector/debugger/scriptParsed.html	2016-05-19 21:11:02 UTC (rev 201181)
@@ -79,10 +79,10 @@
                         foundInlineAttributeEventListenerScript = true;
                     else if (!foundEvalScript && isEvalScript(params))
                         foundEvalScript = true;
+                    else if (!foundCommandLineAPISourceScript && isCommandLineAPISourceScript(params))
+                        foundCommandLineAPISourceScript = true;
                     else if (!foundInjectedScriptSourceScript && isInjectedScriptSourceScript(params))
                         foundInjectedScriptSourceScript = true;
-                    else if (!foundCommandLineAPISourceScript && isCommandLineAPISourceScript(params))
-                        foundCommandLineAPISourceScript = true;
                     else {
                         ProtocolTest.log("UNEXPECTED SCRIPT: " + JSON.stringify(messageObject));
                         foundUnexpectedScript = true;
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to