Title: [224483] trunk/Source/WebCore
Revision
224483
Author
zandober...@gmail.com
Date
2017-11-06 00:05:52 -0800 (Mon, 06 Nov 2017)

Log Message

[Cairo] CairoGlyphToPathTranslator::path() shouldn't fill out the glyph path
https://bugs.webkit.org/show_bug.cgi?id=179159

Reviewed by Michael Catanzaro.

In case of non-zero synthetic bold offset in CairoGlyphToPathTranslator::path(),
cairo_glyph_path() should be called just like in the generic case.
cairo_show_glyphs() performs the actual rasterization of the glyph, but we're
only interested in the generated path operations.

No new tests -- covered by existing tests.

* platform/graphics/cairo/FontCairo.cpp:
(WebCore::CairoGlyphToPathTranslator::path):

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (224482 => 224483)


--- trunk/Source/WebCore/ChangeLog	2017-11-06 07:53:40 UTC (rev 224482)
+++ trunk/Source/WebCore/ChangeLog	2017-11-06 08:05:52 UTC (rev 224483)
@@ -1,3 +1,20 @@
+2017-11-06  Zan Dobersek  <zdober...@igalia.com>
+
+        [Cairo] CairoGlyphToPathTranslator::path() shouldn't fill out the glyph path
+        https://bugs.webkit.org/show_bug.cgi?id=179159
+
+        Reviewed by Michael Catanzaro.
+
+        In case of non-zero synthetic bold offset in CairoGlyphToPathTranslator::path(),
+        cairo_glyph_path() should be called just like in the generic case.
+        cairo_show_glyphs() performs the actual rasterization of the glyph, but we're
+        only interested in the generated path operations.
+
+        No new tests -- covered by existing tests.
+
+        * platform/graphics/cairo/FontCairo.cpp:
+        (WebCore::CairoGlyphToPathTranslator::path):
+
 2017-11-05  Fujii Hironori  <hironori.fu...@sony.com>
 
         [WinCairo] Fix build after r224463

Modified: trunk/Source/WebCore/platform/graphics/cairo/FontCairo.cpp (224482 => 224483)


--- trunk/Source/WebCore/platform/graphics/cairo/FontCairo.cpp	2017-11-06 07:53:40 UTC (rev 224482)
+++ trunk/Source/WebCore/platform/graphics/cairo/FontCairo.cpp	2017-11-06 08:05:52 UTC (rev 224483)
@@ -253,7 +253,7 @@
     float syntheticBoldOffset = m_fontData->syntheticBoldOffset();
     if (syntheticBoldOffset) {
         cairo_translate(path.platformPath()->context(), syntheticBoldOffset, 0);
-        cairo_show_glyphs(path.platformPath()->context(), &cairoGlyph, 1);
+        cairo_glyph_path(path.platformPath()->context(), &cairoGlyph, 1);
     }
 
     path.transform(m_translation);
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to