Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: a32a08ab27d7245b1e8c577a3498690ed5ef85e2
      
https://github.com/WebKit/WebKit/commit/a32a08ab27d7245b1e8c577a3498690ed5ef85e2
  Author: Chris Dumez <cdu...@apple.com>
  Date:   2024-05-23 (Thu, 23 May 2024)

  Changed paths:
    M Source/WebKit/Platform/IPC/Decoder.h
    M Source/WebKit/Platform/IPC/JSIPCBinding.h
    M Source/WebKit/WebProcess/WebPage/IPCTestingAPI.cpp

  Log Message:
  -----------
  Rename IPC::Decoder::buffer() to span()
https://bugs.webkit.org/show_bug.cgi?id=274570

Reviewed by Darin Adler.

Rename IPC::Decoder::buffer() to span() for consistency with other types
(such as IPC::Encoder).

* Source/WebKit/Platform/IPC/Decoder.h:
(IPC::Decoder::span const):
(IPC::Decoder::buffer const): Deleted.
* Source/WebKit/Platform/IPC/JSIPCBinding.h:
(IPC::putJSValueForDecodeArgumentInArray):
* Source/WebKit/WebProcess/WebPage/IPCTestingAPI.cpp:
(WebKit::IPCTestingAPI::jsResultFromReplyDecoder):
(WebKit::IPCTestingAPI::JSMessageListener::didReceiveMessage):
(WebKit::IPCTestingAPI::JSMessageListener::jsDescriptionFromDecoder):

Canonical link: https://commits.webkit.org/279208@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to