Title: [111844] trunk/Source/WebKit/gtk
- Revision
- 111844
- Author
- carlo...@webkit.org
- Date
- 2012-03-23 02:40:30 -0700 (Fri, 23 Mar 2012)
Log Message
Unreviewed. Rename a variable name in API documentation.
Rename keyboard_mode to triggered_with_keyboard in
WebKitWebView::context-menu signal documentation as suggested by
Martin and Gustavo. I forgot to make this change before landing
previous patch.
* webkit/webkitwebview.cpp:
(webkit_web_view_class_init):
Modified Paths
Diff
Modified: trunk/Source/WebKit/gtk/ChangeLog (111843 => 111844)
--- trunk/Source/WebKit/gtk/ChangeLog 2012-03-23 09:29:03 UTC (rev 111843)
+++ trunk/Source/WebKit/gtk/ChangeLog 2012-03-23 09:40:30 UTC (rev 111844)
@@ -1,5 +1,17 @@
2012-03-23 Carlos Garcia Campos <cgar...@igalia.com>
+ Unreviewed. Rename a variable name in API documentation.
+
+ Rename keyboard_mode to triggered_with_keyboard in
+ WebKitWebView::context-menu signal documentation as suggested by
+ Martin and Gustavo. I forgot to make this change before landing
+ previous patch.
+
+ * webkit/webkitwebview.cpp:
+ (webkit_web_view_class_init):
+
+2012-03-23 Carlos Garcia Campos <cgar...@igalia.com>
+
[GTK] Add a signal to allow applications to handle its own context menu
https://bugs.webkit.org/show_bug.cgi?id=49904
Modified: trunk/Source/WebKit/gtk/webkit/webkitwebview.cpp (111843 => 111844)
--- trunk/Source/WebKit/gtk/webkit/webkitwebview.cpp 2012-03-23 09:29:03 UTC (rev 111843)
+++ trunk/Source/WebKit/gtk/webkit/webkitwebview.cpp 2012-03-23 09:40:30 UTC (rev 111844)
@@ -2852,13 +2852,13 @@
* @web_view: the object which received the signal
* @default_menu: the default context menu
* @hit_test_result: a #WebKitHitTestResult with the context of the current position.
- * @keyboard_mode: %TRUE if the context menu was triggered using the keyboard
+ * @triggered_with_keyboard: %TRUE if the context menu was triggered using the keyboard
*
* Emmited when a context menu is about to be displayed to give the application
* a chance to create and handle its own context menu. If you only want to add custom
* options to the default context menu you can simply modify the given @default_menu.
*
- * When @keyboard_mode is %TRUE the coordinates of the given @hit_test_result should be
+ * When @triggered_with_keyboard is %TRUE the coordinates of the given @hit_test_result should be
* used to position the popup menu. When the context menu has been triggered by a
* mouse event you could either use the @hit_test_result coordinates or pass %NULL
* to the #GtkMenuPositionFunc parameter of gtk_menu_popup() function.
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-changes