Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 3fd024ddb79ba481ebe6a2e5d5c9a977f8c69e8e
https://github.com/WebKit/WebKit/commit/3fd024ddb79ba481ebe6a2e5d5c9a977f8c69e8e
Author: Shu-yu Guo <[email protected]>
Date: 2026-07-17 (Fri, 17 Jul 2026)
Changed paths:
M Source/JavaScriptCore/assembler/MacroAssemblerARM64.h
Log Message:
-----------
[JSC] Swap base and offset registers in branchTest{8,16}
https://bugs.webkit.org/show_bug.cgi?id=319635
rdar://182030086
Reviewed by Keith Miller.
In MacroAssemblerARM64, ldrb's signature is (RegisterID dest, RegisterID rn,
RegisterID rm), where rn is the offset register and rm is the memory base
register.
branchTest{8,16} currently passes them in the opposite order, and this PR swaps
it for clarity.
There is no test for this codegen.
* Source/JavaScriptCore/assembler/MacroAssemblerARM64.h:
(JSC::MacroAssemblerARM64::branchTest8):
(JSC::MacroAssemblerARM64::branchTest16):
Canonical link: https://commits.webkit.org/317394@main
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications