Branch: refs/heads/webkitglib/2.54
Home: https://github.com/WebKit/WebKit
Commit: 5cafedf52632070d884fbe7f0006dadb33788865
https://github.com/WebKit/WebKit/commit/5cafedf52632070d884fbe7f0006dadb33788865
Author: Pawel Lampe <[email protected]>
Date: 2026-07-27 (Mon, 27 Jul 2026)
Changed paths:
M Source/WebKit/UIProcess/wpe/SystemSettingsManagerProxyWPE.cpp
M Source/WebKit/WPEPlatform/wpe/WPESettings.cpp
M Source/WebKit/WPEPlatform/wpe/WPESettings.h
Log Message:
-----------
Cherry-pick 317706@main (18d9a420b652).
https://bugs.webkit.org/show_bug.cgi?id=312461
WPEWebKit font rendering has different thickness than WebKitGTK
https://bugs.webkit.org/show_bug.cgi?id=312461
Reviewed by Carlos Garcia Campos.
This change unifies the default font rendering settings between GTK
and WPE.
To be more precise, it changes the WPE's default value for
subpixel layout from RGB to NONE so that it matches the default from
FontRenderOptions that is used by GTK normally.
Canonical link: https://commits.webkit.org/317706@main
Canonical link: https://commits.webkit.org/317695.3@webkitglib/2.54
Commit: 2a4f1495f39deb5cafccfdefe818d92e75d13273
https://github.com/WebKit/WebKit/commit/2a4f1495f39deb5cafccfdefe818d92e75d13273
Author: Enrique Ocaña González <[email protected]>
Date: 2026-07-27 (Mon, 27 Jul 2026)
Changed paths:
M LayoutTests/platform/glib/TestExpectations
A
LayoutTests/platform/glib/imported/w3c/web-platform-tests/media-source/mediasource-remove-expected.txt
M Source/WebCore/platform/graphics/PlatformTimeRanges.cpp
M Source/WebCore/platform/graphics/gstreamer/GStreamerCommon.cpp
M Source/WebCore/platform/graphics/gstreamer/GStreamerCommon.h
M Source/WebCore/platform/graphics/gstreamer/MediaSampleGStreamer.cpp
M Source/WebCore/platform/graphics/gstreamer/MediaSampleGStreamer.h
M Source/WebCore/platform/graphics/gstreamer/mse/AppendPipeline.cpp
Log Message:
-----------
Cherry-pick 317765@main (554e66411358).
https://bugs.webkit.org/show_bug.cgi?id=231019
[MSE][GStreamer] Honor MP4 edit lists
https://bugs.webkit.org/show_bug.cgi?id=231019
Reviewed by Alicia Boya Garcia and Xabier Rodriguez-Calvar.
This patch reintroduces https://commits.webkit.org/251332@main with
even more corrections (basically, keeping the original time fudge factor),
which motivated the last patch revert in bug 231019.
Original author: Alicia Boya Garcia <[email protected]>
Source/WebCore:
This patch takes into consideration the GstSegment attached to a sample to
offset the PTS and DTS.
This ensures accurate timestamps are obtained for MP4 files containing edit
lists (commonly
necessary for files containing video with B frames to have PTS starting at
zero).
Before this was implemented, a workaround was in place based on a heuristic
(DTS = 0 && PTS > 0 &&
PTS < 0.1). The workaround has been removed and replaced by a GStreamer log
warning, because we no
longer believe it to be needed, but we would like to notice about any video
having required it in
theory and failing because of this removal. The heuristic now uses the old
fudge factor (2002/24000
= ~0.083).
The time fudge factor has been centralized to PlatformTimeRanges, so now
it's easier to change in
case of need, but it remains untouched because the old 0.083 value was good
enough to pass the empty
edit in test.mp4 used by Web Platform Tests.
This test fixes improves expectation results and fixes two subtests in
imported/w3c/web-platform-tests/media-source/mediasource-remove.html.
This is a reworked version that fixes an issue where frames that would get
a negative DTS were not
being enqueued properly.
LayoutTests:
Update expectations for mediasource-remove.html in the GStreamer ports, as
a 3 subtests get
fixed.
Canonical link: https://commits.webkit.org/317765@main
Canonical link: https://commits.webkit.org/317695.4@webkitglib/2.54
Commit: c78a5c01c2e6e77ab6c6f72bf8b7c75b9f8a75b2
https://github.com/WebKit/WebKit/commit/c78a5c01c2e6e77ab6c6f72bf8b7c75b9f8a75b2
Author: Carlos Garcia Campos <[email protected]>
Date: 2026-07-27 (Mon, 27 Jul 2026)
Changed paths:
M Source/WebCore/rendering/RenderLayer.cpp
M Source/WebCore/rendering/RenderLayer.h
Log Message:
-----------
Cherry-pick 317721@main (b995ec5503b1).
https://bugs.webkit.org/show_bug.cgi?id=319986
Simplify RenderLayer::calculateLayerBounds() to compute the local clip rect
https://bugs.webkit.org/show_bug.cgi?id=319986
Reviewed by Simon Fraser.
RenderLayer::localClipRect() is public, but only used by
RenderLayer::calculateLayerBounds() so it could be simplified by making
it a simple lambda inside calculateLayerBounds(). This way we don't need
the LocalClipRectMode enum nor the clipExceedsBounds out parameter.
No new tests since this shouldn't change the behavior.
* Source/WebCore/rendering/RenderLayer.cpp:
(WebCore::RenderLayer::calculateClipRects const):
* Source/WebCore/rendering/RenderLayer.h:
Canonical link: https://commits.webkit.org/317721@main
Canonical link: https://commits.webkit.org/317695.5@webkitglib/2.54
Compare: https://github.com/WebKit/WebKit/compare/2bed22b13d67...c78a5c01c2e6
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications