Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 2fe096a108bcb780001c4b882807bbe42021e27d
      
https://github.com/WebKit/WebKit/commit/2fe096a108bcb780001c4b882807bbe42021e27d
  Author: Yulun Wu <[email protected]>
  Date:   2026-07-29 (Wed, 29 Jul 2026)

  Changed paths:
    M Source/WebCore/layout/LayoutState.cpp
    M Source/WebCore/layout/LayoutState.h
    M 
Source/WebCore/layout/integration/LayoutIntegrationFormattingContextLayout.cpp
    M 
Source/WebCore/layout/integration/LayoutIntegrationFormattingContextLayout.h
    M Source/WebCore/layout/integration/LayoutIntegrationUtils.cpp
    M Source/WebCore/layout/integration/LayoutIntegrationUtils.h

  Log Message:
  -----------
  [GFC][LayoutIntegrationUtils] Clarify intent of integration helper functions.
https://bugs.webkit.org/show_bug.cgi?id=320259
<rdar://183165448>

Reviewed by Alan Baradlay.

This PR renames widthConstraint/heightConstraint to 
overridingBorderBoxLogicalWidth/Height
across *FC to better represent what they do.

This PR also renames the misnamed static layoutBoxWithOverridingBorderBoxSize()
to layoutRendererWithOverridingBorderBoxSize(), since it operates on a RenderBox
rather than a Layout::Box. This also cleans up the shared code for two layout 
entry
points into a new layoutRendererAndUpdateBoxGeometry() helper.

No behavior change.

* Source/WebCore/layout/LayoutState.cpp:
(WebCore::Layout::LayoutState::layoutWithFormattingContextForBox const):
* Source/WebCore/layout/LayoutState.h:
* 
Source/WebCore/layout/integration/LayoutIntegrationFormattingContextLayout.cpp:
(WebCore::LayoutIntegration::layoutRendererWithOverridingBorderBoxSize):
(WebCore::LayoutIntegration::layoutRendererAndUpdateBoxGeometry):
(WebCore::LayoutIntegration::layoutWithFormattingContextForBox):
(WebCore::LayoutIntegration::layoutGridItemWithFormattingContext):
(WebCore::LayoutIntegration::layoutBoxWithOverridingBorderBoxSize): Deleted.
* Source/WebCore/layout/integration/LayoutIntegrationFormattingContextLayout.h:
* Source/WebCore/layout/integration/LayoutIntegrationUtils.cpp:
(WebCore::Layout::IntegrationUtils::layoutWithFormattingContextForBox const):
(WebCore::Layout::IntegrationUtils::layoutGridItem const):
* Source/WebCore/layout/integration/LayoutIntegrationUtils.h:
(WebCore::Layout::IntegrationUtils::layoutWithFormattingContextForBox):

Canonical link: https://commits.webkit.org/318206@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to