Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: c36a2f597edb0ad56085a18c4e0b2091806a3b86
      
https://github.com/WebKit/WebKit/commit/c36a2f597edb0ad56085a18c4e0b2091806a3b86
  Author: Alan Baradlay <[email protected]>
  Date:   2026-09-11 (Fri, 11 Sep 2026)

  Changed paths:
    M Source/WebCore/page/SpatialNavigation.cpp
    M Source/WebCore/rendering/LegacyInlineIterator.h
    M Source/WebCore/rendering/LegacyLineLayout.cpp
    M Source/WebCore/rendering/LogicalSelectionOffsetCachesInlines.h
    M Source/WebCore/rendering/RenderBlockFlow.cpp
    M Source/WebCore/rendering/RenderFragmentedFlow.cpp
    M Source/WebCore/rendering/RenderInline.cpp
    M Source/WebCore/rendering/RenderInline.h
    M Source/WebCore/rendering/RenderLayer.cpp
    M Source/WebCore/rendering/RenderObject.h
    M Source/WebCore/rendering/line/LineBreaker.cpp
    M Source/WebCore/rendering/updating/RenderTreeBuilder.cpp
    M
Source/WebCore/rendering/updating/RenderTreeUpdater.cpp

  Log Message:
  -----------
  [cleanup] Rename RenderObject::isRenderInline() to isInlineBox()
https://bugs.webkit.org/show_bug.cgi?id=323761
<rdar://problem/187019873>

Reviewed by Antti Koivisto.

This is in preparation for removing RenderInline renderer.

The call sites are asking whether the renderer is an inline box, which is what 
isInlineBox() already
means everywhere else in inline layout (InlineLevelBox, InlineDisplayBox, 
InlineIteratorBox).

* Source/WebCore/page/SpatialNavigation.cpp:
* Source/WebCore/rendering/LegacyInlineIterator.h:
* Source/WebCore/rendering/LegacyLineLayout.cpp:
* Source/WebCore/rendering/LogicalSelectionOffsetCachesInlines.h:
* Source/WebCore/rendering/RenderBlockFlow.cpp:
* Source/WebCore/rendering/RenderFragmentedFlow.cpp:
* Source/WebCore/rendering/RenderInline.cpp:
* Source/WebCore/rendering/RenderInline.h:
* Source/WebCore/rendering/RenderLayer.cpp:
*
Source/WebCore/rendering/RenderObject.h:
* Source/WebCore/rendering/line/LineBreaker.cpp:
* Source/WebCore/rendering/updating/RenderTreeBuilder.cpp:
* Source/WebCore/rendering/updating/RenderTreeUpdater.cpp:

Canonical link: 
https://flagged.apple.com:443/proxy?t2=DE0m0D8dG2&o=aHR0cHM6Ly9jb21taXRzLndlYmtpdC5vcmcvMzIwOTMyQG1haW4=&emid=6d83b014-c5b6-48bc-8612-01018cdbed75&c=11



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to