Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 919435e98e5c41d9a37ff11bc2df8f8e5441778e
      
https://github.com/WebKit/WebKit/commit/919435e98e5c41d9a37ff11bc2df8f8e5441778e
  Author: Anne van Kesteren <[email protected]>
  Date:   2026-09-22 (Tue, 22 Sep 2026)

  Changed paths:
    M Source/WebCore/html/HTMLOptionElement.cpp
    M Source/WebCore/html/HTMLSelectElement.cpp
    M Source/WebCore/html/HTMLSelectElement.h

  Log Message:
  -----------
  Rename usesMenuListDeprecated() to isSingleSelectDropdownBox()
https://bugs.webkit.org/show_bug.cgi?id=324620

Reviewed by Aditya Keerthi and Tim Nguyen.

The semantics of this method always were about select elements that allow
for a singular selection and use a dropdown box.

Bug 324529 will make this method depend on the appearance value which is
why a change from "menu list" to "dropdown" is made. Dropdown is the
terminology the standard uses and is renderer-agnostic.

usesMenuList() remains as-is as it cannot be made to depend on the
appearance value due to :-internal-uses-menulist also depending on it.

Canonical link: https://commits.webkit.org/321580@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to