Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: b2ec71d3462f3b3eb0747cebc7893b626b99f205
      
https://github.com/WebKit/WebKit/commit/b2ec71d3462f3b3eb0747cebc7893b626b99f205
  Author: Anne van Kesteren <[email protected]>
  Date:   2026-09-22 (Tue, 22 Sep 2026)

  Changed paths:
    M Source/WebCore/css/CSSPseudoSelectors.json
    M Source/WebCore/css/SelectorChecker.cpp
    M Source/WebCore/css/SelectorCheckerTestFunctions.h
    M Source/WebCore/cssjit/SelectorCompiler.cpp
    M Source/WebCore/html/HTMLSelectElement.cpp
    M Source/WebCore/html/HTMLSelectElement.h

  Log Message:
  -----------
  Add HTMLSelectElement::preferredSize() and 
:-internal-select-preferred-size-one
https://bugs.webkit.org/show_bug.cgi?id=324790

Reviewed by Tim Nguyen.

Preparation for the base appearance list box and multi-select dropdown box, 
where
the preferred size picks the box type rather than the multiple attribute. 1 is a
dropdown box and anything larger is a list box, whether or not multiple is 
present.

The user agent stylesheet has to select on that, and :-internal-uses-menulist 
cannot
express it because it needs to match native appearance. So add a pseudo-class 
for
the preferred size.

The specification calls this the display size. Renaming it there for clarity is 
part
of the open issue about size=0, which preferredSize() treats as an absent 
attribute,
like RenderListBox::size() does, rather than as a preferred size of 0:

https://github.com/whatwg/html/issues/12977
Canonical link: https://commits.webkit.org/321595@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to