Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: e512535443a1af21e55466168394d4499edfd6b7
https://github.com/WebKit/WebKit/commit/e512535443a1af21e55466168394d4499edfd6b7
Author: Alex Christensen <[email protected]>
Date: 2026-09-25 (Fri, 25 Sep 2026)
Changed paths:
M Source/WTF/wtf/spi/cocoa/SecuritySPI.h
M Source/WebKit/Configurations/AllowedSPI.toml
M Source/WebKit/NetworkProcess/QualifiedServerTrustFetch.cpp
M Source/WebKit/NetworkProcess/cocoa/SecuritySoftLink.h
M Source/WebKit/NetworkProcess/cocoa/SecuritySoftLink.mm
Log Message:
-----------
Rename SecQWACTLSBindingVerify to SecTrustCreateAndVerifyQWACTLSBinding
https://bugs.webkit.org/show_bug.cgi?id=325168
rdar://188298110
Reviewed by Chris Dumez.
More review feedback on rdar://181532378 caused another name change.
This is like 321253@main, but again! Since it's not the same name with
a different signature, we don't need a compile guard, and I found a small
error in 321253@main where I had adoptCF instead of WTF::move.
* Source/WTF/wtf/spi/cocoa/SecuritySPI.h:
* Source/WebKit/Configurations/AllowedSPI.toml:
* Source/WebKit/NetworkProcess/QualifiedServerTrustFetch.cpp:
(WebKit::QualifiedServerTrustFetch::didFinishLoading):
* Source/WebKit/NetworkProcess/cocoa/SecuritySoftLink.h:
* Source/WebKit/NetworkProcess/cocoa/SecuritySoftLink.mm:
Canonical link: https://commits.webkit.org/321916@main
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications