Title: [173608] trunk/Source
Revision
173608
Author
dba...@webkit.org
Date
2014-09-14 18:51:56 -0700 (Sun, 14 Sep 2014)

Log Message

[iOS] Attempt to fix the iOS build after <http://trac.webkit.org/changeset/173606>
(https://bugs.webkit.org/show_bug.cgi?id=136789)

Substitute Node::countChildNodes() for Node::childNodeCount() in more places.

Source/WebCore:

Although I updated a comment in WebCore::lastOffsetForEditing() (defined in file
editing/htmlediting.cpp) to refer to Node::countChildNodes(), I'm unclear what the
comment is trying to explain that isn't otherwise explained by the code or the
comments that precede this function. Specifically, I don't understand the use of
the word "preempt" in the comment. We should look to improve the readability of
this comment.

* editing/htmlediting.cpp:
(WebCore::lastOffsetForEditing):
* page/ios/FrameIOS.mm:
(WebCore::Frame::interpretationsForCurrentRoot):

Source/WebKit/mac:

* WebView/WebFrame.mm:
(-[WebFrame focusedNodeHasContent]):

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (173607 => 173608)


--- trunk/Source/WebCore/ChangeLog	2014-09-14 22:19:19 UTC (rev 173607)
+++ trunk/Source/WebCore/ChangeLog	2014-09-15 01:51:56 UTC (rev 173608)
@@ -1,3 +1,22 @@
+2014-09-14  Daniel Bates  <daba...@apple.com>
+
+        [iOS] Attempt to fix the iOS build after <http://trac.webkit.org/changeset/173606>
+        (https://bugs.webkit.org/show_bug.cgi?id=136789)
+
+        Substitute Node::countChildNodes() for Node::childNodeCount() in more places.
+
+        Although I updated a comment in WebCore::lastOffsetForEditing() (defined in file
+        editing/htmlediting.cpp) to refer to Node::countChildNodes(), I'm unclear what the
+        comment is trying to explain that isn't otherwise explained by the code or the
+        comments that precede this function. Specifically, I don't understand the use of
+        the word "preempt" in the comment. We should look to improve the readability of
+        this comment.
+
+        * editing/htmlediting.cpp:
+        (WebCore::lastOffsetForEditing):
+        * page/ios/FrameIOS.mm:
+        (WebCore::Frame::interpretationsForCurrentRoot):
+
 2014-09-14  Chris Dumez  <cdu...@apple.com>
 
         Drop NodeTraversal::nextSkippingChildren() overload taking a ContainerNode

Modified: trunk/Source/WebCore/editing/htmlediting.cpp (173607 => 173608)


--- trunk/Source/WebCore/editing/htmlediting.cpp	2014-09-14 22:19:19 UTC (rev 173607)
+++ trunk/Source/WebCore/editing/htmlediting.cpp	2014-09-15 01:51:56 UTC (rev 173608)
@@ -345,7 +345,7 @@
     if (node->hasChildNodes())
         return node->countChildNodes();
 
-    // NOTE: This should preempt the childNodeCount for, e.g., select nodes
+    // NOTE: This should preempt the countChildNodes() for, e.g., select nodes (what does this mean)?
     if (editingIgnoresContent(node))
         return 1;
 

Modified: trunk/Source/WebCore/page/ios/FrameIOS.mm (173607 => 173608)


--- trunk/Source/WebCore/page/ios/FrameIOS.mm	2014-09-14 22:19:19 UTC (rev 173607)
+++ trunk/Source/WebCore/page/ios/FrameIOS.mm	2014-09-15 01:51:56 UTC (rev 173608)
@@ -745,7 +745,7 @@
         return nil;
 
     Element* root = selection().selection().selectionType() == VisibleSelection::NoSelection ? document()->body() : selection().selection().rootEditableElement();
-    unsigned rootChildCount = root->childNodeCount();
+    unsigned rootChildCount = root->countChildNodes();
     RefPtr<Range> rangeOfRootContents = Range::create(*document(), createLegacyEditingPosition(root, 0), createLegacyEditingPosition(root, rootChildCount));
 
     Vector<DocumentMarker*> markersInRoot = document()->markers().markersInRange(rangeOfRootContents.get(), DocumentMarker::DictationPhraseWithAlternatives);

Modified: trunk/Source/WebKit/mac/ChangeLog (173607 => 173608)


--- trunk/Source/WebKit/mac/ChangeLog	2014-09-14 22:19:19 UTC (rev 173607)
+++ trunk/Source/WebKit/mac/ChangeLog	2014-09-15 01:51:56 UTC (rev 173608)
@@ -1,3 +1,13 @@
+2014-09-14  Daniel Bates  <daba...@apple.com>
+
+        [iOS] Attempt to fix the iOS build after <http://trac.webkit.org/changeset/173606>
+        (https://bugs.webkit.org/show_bug.cgi?id=136789)
+
+        Substitute Node::countChildNodes() for Node::childNodeCount() in more places.
+
+        * WebView/WebFrame.mm:
+        (-[WebFrame focusedNodeHasContent]):
+
 2014-09-14  Chris Dumez  <cdu...@apple.com>
 
         Rename Node::childNodeCount() to countChildNodes() and avoid inefficient uses

Modified: trunk/Source/WebKit/mac/WebView/WebFrame.mm (173607 => 173608)


--- trunk/Source/WebKit/mac/WebView/WebFrame.mm	2014-09-14 22:19:19 UTC (rev 173607)
+++ trunk/Source/WebKit/mac/WebView/WebFrame.mm	2014-09-15 01:51:56 UTC (rev 173608)
@@ -2346,7 +2346,7 @@
         return NO;
 
     VisiblePosition first(createLegacyEditingPosition(root, 0));
-    VisiblePosition last(createLegacyEditingPosition(root, root->childNodeCount()));
+    VisiblePosition last(createLegacyEditingPosition(root, root->countChildNodes()));
     return first != last;
 }
 
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to