Title: [195396] trunk/Tools
Revision
195396
Author
fpi...@apple.com
Date
2016-01-20 19:20:32 -0800 (Wed, 20 Jan 2016)

Log Message

Unreviewed, revert accidental unreviewed commit.

* Scripts/display-profiler-output:

Modified Paths

Diff

Modified: trunk/Tools/ChangeLog (195395 => 195396)


--- trunk/Tools/ChangeLog	2016-01-21 03:12:55 UTC (rev 195395)
+++ trunk/Tools/ChangeLog	2016-01-21 03:20:32 UTC (rev 195396)
@@ -1,3 +1,9 @@
+2016-01-20  Filip Pizlo  <fpi...@apple.com>
+
+        Unreviewed, revert accidental unreviewed commit.
+
+        * Scripts/display-profiler-output:
+
 2016-01-20  Jason Marcell  <jmarc...@apple.com>
 
         Refactor compareIterations to remove duplicate code.

Modified: trunk/Tools/Scripts/display-profiler-output (195395 => 195396)


--- trunk/Tools/Scripts/display-profiler-output	2016-01-21 03:12:55 UTC (rev 195395)
+++ trunk/Tools/Scripts/display-profiler-output	2016-01-21 03:20:32 UTC (rev 195396)
@@ -535,7 +535,7 @@
     end
 end
 
-def summary(mode, order)
+def summary(mode)
     remaining = screenWidth
     
     # Figure out how many columns we need for the code block names, and for counts
@@ -618,14 +618,7 @@
     puts
     $bytecodes.sort {
         | a, b |
-        case order
-        when :bytecode
-            b.totalMaxTopExecutionCount <=> a.totalMaxTopExecutionCount
-        when :machine
-            b.totalMaxBottomExecutionCount <=> a.totalMaxBottomExecutionCount
-        else
-            raise
-        end
+        b.totalMaxTopExecutionCount <=> a.totalMaxTopExecutionCount
     }.each {
         | bytecode |
         print(center(bytecode.name(hashCols), hashCols))
@@ -745,13 +738,9 @@
     when "quit", "q", "exit"
         exit 0
     when "summary", "s"
-        summary(:summary, :bytecode)
+        summary(:summary)
     when "full", "f"
-        if args[0] and (args[0] == "m" or args[0] == "machine")
-            summary(:full, :machine)
-        else
-            summary(:full, :bytecode)
-        end
+        summary(:full)
     when "source"
         if args.length != 1
             puts "Usage: source <code block hash>"
_______________________________________________
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to