Hi everyone,

The WebKit codebase has an inconsistent mix of `while (true)` and `for (;;)`. 
Given 2/3 of the usages are `while (true)` and only 1/3 is `for (;;)` from code 
search, I would suggest enforcing `while (true)`. I also think it is generally 
more explicit and readable than `for (;;)`. If everyone agrees, I’ll enforce 
this via webkit-style, so we can end up in a consistent place.

What does everyone think?

Cheers,
Tim
_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev

Reply via email to