+1 for removing the code.  duplicate code is confusing and defeats the
purpose of "single responsibility per object".

Single interface for single setting is a bit overboard, and i'm very pro
"slim interfaces". =)

On 10/16/06, Eelco Hillenius <[EMAIL PROTECTED]> wrote:

Yesterday I removed some double app settings, like
isAjaxDebugModeEnabled() that was defined both in IAjaxSettings
(removed) and in IDebugSettings. I did this because I was creating
that JMX code, and thought someone made copy 'n paste bug/ forgot to
remove a method after refactoring. Turns out, it was on purpose.

This is a vote to find out whether people want this change reversed.

I'm -1 because I think it's just crazy to have multiple interfaces
with the same method sigs just for convenience. Imo it's bloat without
real purpose, and it's even confusing. Imagine sitting behind that JMX
interface and wondering which isAjaxDebugModeEnabled you should set.

Also, I removed IAjaxSettings as isAjaxDebugModeEnabled() was the only
method in it. I don't think we need to go back to just one settings
interface, but we don't have to end up with too many of them either.
For instance, having framework settings as a different interface is ok
now that we have it, but wouldn't be my choice if we had to do it over
again.

Votes please?

Eelco

Reply via email to