This type of construct seems popular in the wine source:

while (isspace(*GL_Extensions)) GL_Extensions++;
Start = GL_Extensions;

Or even worse (I've seen this in winex11.drv, and it took me quite a long time until I understood it - it was part of a larger block with a lot these constructs):

if (cond) do_sth();
    do_sth_else();

This indentation is so utterly stupid, it makes my brain hurt (I'm sure I'm not the only one)!! I don't know what AJs stance is on code readability and I know that there are no official coding style guidelines, but can we please avoid this? Can we agree on a set of fundamental style rules? To make peer-reviewing patches easier? And for people not familiar with the code easier to understand it? Please?

tom


Reply via email to