Mikołaj Zalewski <[EMAIL PROTECTED]> writes: > diff --git a/programs/services/services.c b/programs/services/services.c > index 36ed117..b166d51 100644 > --- a/programs/services/services.c > +++ b/programs/services/services.c > @@ -344,7 +344,7 @@ struct service_entry > *scmdatabase_find_service_by_displayname(struct scmdatabase > > LIST_FOR_EACH_ENTRY(service, &db->services, struct service_entry, entry) > { > - if (strcmpiW(name, service->config.lpDisplayName) == 0) > + if (strcmpiW(name, get_display_name(service)) == 0) > return service; > }
You should not change scmdatabase_find_service_by_displayname, it does what its name implies. You should fix the callers where necessary. -- Alexandre Julliard [EMAIL PROTECTED]