I have changed the operators += and friends from "op_add_assign" to
just "op_iadd" as python has, where "i" stands for "inplace".
Additionally the "=" operator is now just "op_set" instead of
"op_assign". I doubt this affects anyone as they there weren't many of
them, but there will be.
Anyone think of better names? Currently they're similar to the names
the python uses, but without the extra ugly underscores (__eq__).
It would be nice to just have a single leading underscore "_eq", but
that is currently used to designate that the base class function
should be called. Logic could be written to differentiate between
them, but it'd have to be run every time for an operator call and slow
things down... maybe it wouldn't be a big deal and the single
underscore seems a little more elegant... any thoughts about this?
Regards,
John Labenski
"==" = "op_eq"
"!=" = "op_ne"
"<" = "op_lt"
">" = "op_gt"
"<=" = "op_le"
">=" = "op_ge"
"|" = "op_or"
"&" = "op_and"
"||" = "op_lor" note: "lor" stands for logical (boolean) or, same for "land."
"&&" = "op_land"
"!" = "op_not"
"^" = "op_xor"
"++" = "op_inc"
"--" = "op_dec"
"- (unary)" = "op_neg"
"=" = op_set
"+" = "op_add"
"-" = "op_sub"
"*" = "op_mul"
"/" = "op_div"
"+=" = "op_iadd" note: ixxx stands for "inplace" as it modifies the
original object.
"-=" = "op_isub"
"*=" = "op_imul"
"/=" = "op_idiv"
"%=" = "op_imod"
"&=" = "op_iand"
"|=" = "op_ior"
"^=" = "op_ixor"
-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
_______________________________________________
wxlua-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/wxlua-users