On 09/11/2017 02:39 PM, Andrew Cooper wrote: > On 11/09/17 14:27, George Dunlap wrote: >> On 09/08/2017 05:05 PM, Alexandru Isaila wrote: >>> diff --git a/xen/include/asm-x86/hvm/support.h >>> b/xen/include/asm-x86/hvm/support.h >>> index b18dbb6..e3b035d 100644 >>> --- a/xen/include/asm-x86/hvm/support.h >>> +++ b/xen/include/asm-x86/hvm/support.h >>> @@ -53,23 +53,23 @@ extern unsigned int opt_hvm_debug_level; >>> >>> extern unsigned long hvm_io_bitmap[]; >>> >>> -enum hvm_copy_result { >>> - HVMCOPY_okay = 0, >>> - HVMCOPY_bad_gva_to_gfn, >>> - HVMCOPY_bad_gfn_to_mfn, >>> - HVMCOPY_unhandleable, >>> - HVMCOPY_gfn_paged_out, >>> - HVMCOPY_gfn_shared, >>> +enum hvm_translation_result { >>> + HVMTRANS_okay, >>> + HVMTRANS_bad_linear_to_gfn, >>> + HVMTRANS_bad_gfn_to_mfn, >>> + HVMTRANS_unhandleable, >>> + HVMTRANS_gfn_paged_out, >>> + HVMTRANS_gfn_shared, >> Somehow "translation result" doesn't seem like the right name for this. >> gfn_to_mfn is a translation result; linear_to_gfn includes access checks. >> >> I'll admit though that by the end of the series, "Copy result" is *also* >> not the right name for it, and I can't think of a better name at the moment. > > Architecturally, "translation" is the most accurate term. > > This entire set of infrastructure will improve in my longterm emulator > plans.
The series as a whole definitely look useful, and like I said, I can't think of a better name (Wei's suggestion of "access" seems inappropriate to me for the same reasons "translation" does), so I don't object to this being checked in as-is: Acked-by: George Dunlap <george.dun...@citrix.com> -George _______________________________________________ Xen-devel mailing list Xen-devel@lists.xen.org https://lists.xen.org/xen-devel