>>> On 15.06.15 at 14:28, <wei.w.w...@intel.com> wrote:
> On 15/06/2015 17:15, Jan Beulich wrote:
>> >>> On 15.06.15 at 02:30, <wei.w.w...@intel.com> wrote:
>> > We actually want it be intel_pstate specific. If maintainers agree, I
>> > think renaming it to intel_pstate_policy is a good option.
>> 
>> No, this name is just ugly. If you need driver specific data, have a void 
> pointer
>> in the generic structure; the driver can then allocate memory to be pointed
>> to by that, and can store there whatever private data it needs.
> 
> OK. I plan to make the following changes:
> 
> 1) in cpufreq_policy, add a field - void *private_data;
> 
> 
> 2) add a new structure:
>  struct intel_pstate_policy {
>       unsigned int policy;
> }

struct intel_pstate_private or struct intel_pstate_data please.

Jan


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

Reply via email to