On Thu, 2015-07-09 at 19:26 +0100, Andrew Cooper wrote:

> @@ -3349,6 +3353,8 @@ struct libxl__stream_read_state {
>      LIBXL_STAILQ_HEAD(, libxl__sr_record_buf) record_queue;
>      enum {
>          SRS_PHASE_NORMAL,
> +        SRS_PHASE_BUFFERING,
> +        SRS_PHASE_UNBUFFERING,

I'd be inclined towards calling the latter DRAINING or PROCESSING or
some such, perhaps tying into my comment about the separate recursion
guard thing earlier on in the series.

But that's a bikeshedding issue on an internal thing so my only real
comment is:

> +    if (rc == 0)
> +        ret = 0; /* Success */
> +    else if (stream->phase == SRS_PHASE_BUFFERING)
> +        ret = 2; /* Failover */
> +    else
> +        ret = 1; /* Error (fatal) */

Maybe we should have had an enum or some #defines for these (this is
really a comment on some previous patch).

Ian.


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

Reply via email to