On Mon, Jun 20, 2016 at 9:15 AM, Jan Beulich <jbeul...@suse.com> wrote:
>>>> On 18.06.16 at 01:12, <dario.faggi...@citrix.com> wrote:
>> @@ -1484,6 +1489,23 @@ csched2_cpu_pick(const struct scheduler *ops, struct 
>> vcpu *vc)
>>  out_up:
>>      spin_unlock(&prv->lock);
>>
>> +    /* TRACE */
>> +    {
>> +        struct {
>> +            uint64_t b_avgload;
>> +            unsigned vcpu:16, dom:16;
>> +            unsigned rq_id:16, new_cpu:16;
>> +       } d;
>> +        d.b_avgload = prv->rqd[min_rqi].b_avgload;
>> +        d.dom = vc->domain->domain_id;
>> +        d.vcpu = vc->vcpu_id;
>> +        d.rq_id = c2r(ops, new_cpu);
>> +        d.new_cpu = new_cpu;
>
> I guess this follows pre-existing style, but it would seem more natural
> to me for the variable to have an initializer instead of this series of
> assignments.

Well that doesn't actually save you that much typing, and I think it's
probably (slightly) less easy to read.  But the biggest thing at this
point is that it's inconsistent with what's there. :-)

 -George

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
https://lists.xen.org/xen-devel

Reply via email to