On 14/09/16 16:14, Tamas K Lengyel wrote:
On Wed, Sep 14, 2016 at 3:33 AM, Julien Grall <julien.gr...@arm.com> wrote:
Hello Tamas,

On 13/09/16 19:12, Tamas K Lengyel wrote:

diff --git a/xen/include/asm-arm/p2m.h b/xen/include/asm-arm/p2m.h
index 53c4d78..5e9bc54 100644
--- a/xen/include/asm-arm/p2m.h
+++ b/xen/include/asm-arm/p2m.h
@@ -121,10 +121,10 @@ typedef enum {
                              p2m_to_mask(p2m_map_foreign)))

 static inline
-void p2m_mem_access_emulate_check(struct vcpu *v,
+bool_t p2m_mem_access_emulate_check(struct vcpu *v,
                                   const vm_event_response_t *rsp)


s/bool_t/bool/ and please indent properly the second line.

Fine by me but bool_t is used throughout p2m.h and I see no use of
just bool. Is there actually any difference between the two to warrant
enforcing one over the other?

bool_t has been turned into an alias to bool recently. Moving all the source code from one to another is a long task (very similar to mfn/gfn typesafe).

However, new code should use bool and not bool_t.

Regards,

--
Julien Grall

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
https://lists.xen.org/xen-devel

Reply via email to