On Sat, Mar 05, 2022 at 09:38:23PM +0800, zhanglianjie wrote: > Use helper macro __ATTR_RW to define HYPERVISOR_ATTR_RW to make code more > clear. > Minor readability improvement. > > Signed-off-by: zhanglianjie <zhanglian...@uniontech.com>
Is this the name you sign legal documents with? (I have to ask...) > > diff --git a/drivers/xen/sys-hypervisor.c b/drivers/xen/sys-hypervisor.c > index feb1d16252e7..fcb0792f090e 100644 > --- a/drivers/xen/sys-hypervisor.c > +++ b/drivers/xen/sys-hypervisor.c > @@ -22,11 +22,10 @@ > #endif > > #define HYPERVISOR_ATTR_RO(_name) \ > -static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name) > +static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name) Why change this line? That's not relevant to this change :( thanks, greg k-h