> On 8 Mar 2022, at 19:46, Vikram Garhwal <fnu.vik...@xilinx.com> wrote:
> 
> Rename iommu_dt_device_is_assigned() to iommu_dt_device_is_assigned_lock().
> 
> Moving spin_lock to caller was done to prevent the concurrent access to
> iommu_dt_device_is_assigned while doing add/remove/assign/deassign.
> 
> Signed-off-by: Vikram Garhwal <fnu.vik...@xilinx.com>
> ---
> xen/drivers/passthrough/device_tree.c | 11 +++++++----
> 1 file changed, 7 insertions(+), 4 deletions(-)
> 
> diff --git a/xen/drivers/passthrough/device_tree.c 
> b/xen/drivers/passthrough/device_tree.c
> index 98f2aa0dad..b3b04f8e03 100644
> --- a/xen/drivers/passthrough/device_tree.c
> +++ b/xen/drivers/passthrough/device_tree.c
> @@ -83,16 +83,14 @@ fail:
>     return rc;
> }
> 
> -static bool_t iommu_dt_device_is_assigned(const struct dt_device_node *dev)
> +static bool_t iommu_dt_device_is_assigned_lock(const struct dt_device_node 
> *dev)
> {
>     bool_t assigned = 0;
> 

You can add an ASSERT(spin_is_locked(&dtdevs_lock)); to be sure, however the 
name is pretty clear,
so for me with or without it:

Reviewed-by: Luca Fancellu <luca.fance...@arm.com>

>     if ( !dt_device_is_protected(dev) )
>         return 0;
> 
> -    spin_lock(&dtdevs_lock);
>     assigned = !list_empty(&dev->domain_list);
> -    spin_unlock(&dtdevs_lock);
> 
>     return assigned;
> }
> @@ -225,12 +223,17 @@ int iommu_do_dt_domctl(struct xen_domctl *domctl, 
> struct domain *d,
> 
>         if ( domctl->cmd == XEN_DOMCTL_test_assign_device )
>         {
> -            if ( iommu_dt_device_is_assigned(dev) )
> +            spin_lock(&dtdevs_lock);
> +
> +            if ( iommu_dt_device_is_assigned_lock(dev) )
>             {
>                 printk(XENLOG_G_ERR "%s already assigned.\n",
>                        dt_node_full_name(dev));
>                 ret = -EINVAL;
>             }
> +
> +            spin_unlock(&dtdevs_lock);
> +
>             break;
>         }
> 
> 


Reply via email to