The aim of this series is to add a lookup_page method for AMD IOMMU analogous to that recently added for VT-d. That is done by the last patch. The first five patches are cleanup of the AMD IOMMU code, and patch six modifies the VT-d code to remove a semantic problem.
Paul Durrant (7): amd-iommu: don't domain_crash() inside map/unmap_page() amd-iommu: re-name u8/16/32/64 to uint8/16/32/64_t amd-iommu: convert all bool_t to bool amd-iommu: reduce code duplication... amd-iommu: introduce new get/set_iommu_pde_info() functions... vtd: change lookup_page failure semantics amd-iommu: add lookup_page method to iommu_ops xen/drivers/passthrough/amd/iommu_map.c | 551 +++++++++++++++----------- xen/drivers/passthrough/amd/pci_amd_iommu.c | 1 + xen/drivers/passthrough/vtd/iommu.c | 5 +- xen/include/asm-x86/hvm/svm/amd-iommu-proto.h | 2 + 4 files changed, 317 insertions(+), 242 deletions(-) --- Cc: Andrew Cooper <andrew.coop...@citrix.com> Cc: Brian Woods <brian.wo...@amd.com> Cc: Jan Beulich <jbeul...@suse.com> Cc: Kevin Tian <kevin.t...@intel.com> Cc: Suravee Suthikulpanit <suravee.suthikulpa...@amd.com> Cc: Wei Liu <wei.l...@citrix.com> -- 2.11.0 _______________________________________________ Xen-devel mailing list Xen-devel@lists.xenproject.org https://lists.xenproject.org/mailman/listinfo/xen-devel