Tilman Sauerbeck wrote:
The function names used on the server side are generated from the names
listed in the XML file. By referencing those functions names in the
generated code, we can be sure that we won't forget to implement any IPC
methods (the build would fail).

Thats great.

When I wrote the XML file, I tweaked the method names here and there,
eg properly camel-casing _add_idlist as _add_id_list instead.
I can undo those tweaks and copy the names from the clientlib though,
but I suspect this will still cause a few renames on the server side.

I think it could be a good idea to do the tweaks separately. I'm sure most of the renames are good, but I agree with seb that the idlist should be idlist, not id_list. So feel free to do the renames, but I'd prefere them to be done separately - they can even be merged before genipc is merged (and have a nice "hey! now clientlib is genipc:ed, but clientlib is still exactly the same").

But I'm still a bit conserned about method (and object) name harmonization. Are names same in all bindings? And more important: Should they be same in all bindings? (and by same I mean something that can be automatically converted, such as do_crazy_stuff -> doCrazyStuff if stupidLanguageUsed). Maybe some language may want to fold addURL/addId/addIdlist into one method called add (playlist.add(url="foo"), playlist.add(id=123)).

Also the "type" attribute on the "object" tags feels very unclean. It would be much better if there was a proper 1:1 mapping between server and client sides.

 anders


--
_______________________________________________
Xmms2-devel mailing list
Xmms2-devel@lists.xmms.se
http://lists.xmms.se/cgi-bin/mailman/listinfo/xmms2-devel

Reply via email to