Hello.

I want to rename NozzleFactory to SpheresFactory and make it virtual by adding an empty function pickRandomPosition(). Derived classes will override this function in accordance with the required geometry of the spheres generation region. I want to add two derived classes: CircularFactory (the region is a disk or a cylinder) and QuadroFactory (the region is a rectangle or a rectangular parallelepiped). Also I want rename current SpheresFactory class to FacetedFactory (or FreeFactory?) and make it derived from new SpheresFactory (although its algorithm needs some work). Is anyone against or any comments?

--
Best regards,

Sergei Dorofeenko,
Cand. Phys.-Mat. Sci.

Institute of Problems of Chemical Physics,
Chernogolovka, Moscow region, Russia.

e-mail: dorofee...@icp.ac.ru



_______________________________________________
Mailing list: https://launchpad.net/~yade-dev
Post to     : yade-dev@lists.launchpad.net
Unsubscribe : https://launchpad.net/~yade-dev
More help   : https://help.launchpad.net/ListHelp

Reply via email to