[ 
https://issues.apache.org/jira/browse/YARN-6022?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15770852#comment-15770852
 ] 

Wangda Tan commented on YARN-6022:
----------------------------------

bq. Have a SchedulerResourceRequest wrapper class that takes either a standard 
ResourceRequest or UpdateContainerRequest in the constructor.

If AbstractResourceRequest is only created for:
{code}
public void normalizeRequest(AbstractResourceRequest ask)
{code}

I would prefer to rename it to: normalizeCapability, change parameter from 
AbstractResourceRequest to Resource, returns normalized Resource for input 
Resource.
Or we can direct invoke setMemory/setVirtualCores to update the Resource 
in-place.

Thoughts?

> Revert changes of AbstractResourceRequest
> -----------------------------------------
>
>                 Key: YARN-6022
>                 URL: https://issues.apache.org/jira/browse/YARN-6022
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Wangda Tan
>            Priority: Blocker
>
> YARN-5774 added AbstractResourceRequest to make easier internal scheduler 
> change, this is not a correct approach: For example, with this change, we 
> need to make AbstractResourceRequest to be public/stable. And end users can 
> use it like:
> {code}
> AbstractResourceRequest request = ...
> request.setCapability(...)
> {code}
> But AbstractResourceRequest should not be visible by application at all. 
> We need to revert it from branch-2.8 / branch-2 / trunk. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to