[ 
https://issues.apache.org/jira/browse/YARN-5331?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15981760#comment-15981760
 ] 

Subru Krishnan commented on YARN-5331:
--------------------------------------

Thanks [~ajsangeetha] for working on this. I looked at the latest patch (v8) 
and have a few minor comments:
  * I feel it's better if {{PeriodicRLESparseResourceAllocation}} extends 
{{RLESparseResourceAllocation}} as it's a specialization and not composition.
  * Following the above comment, we should rename *getMaxPeriodicCapacity* to 
*getMaximumCapacityInInterval* and use the interval length for period 
implicitly (call out in Javadoc). This will also align with 
*getMinimumCapacityInInterval*.
  * To improve efficiency, the specified *timePeriod* should be the 
*maxTimePeriod*. This will allow us to auto extend period till we hit the max 
which I feel is reasonable as otherwise we'll be unbounded if user decides to 
input prime numbers as currently we'll be storing multiple instances if the 
user requested periods are small. For e.g: 24 instances of an hourly job if 
timePeriod is one day.

> Extend RLESparseResourceAllocation with period for supporting recurring 
> reservations in YARN ReservationSystem
> --------------------------------------------------------------------------------------------------------------
>
>                 Key: YARN-5331
>                 URL: https://issues.apache.org/jira/browse/YARN-5331
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Subru Krishnan
>            Assignee: Sangeetha Abdu Jyothi
>              Labels: oct16-medium
>         Attachments: YARN-5331.001.patch, YARN-5331.002.patch, 
> YARN-5331.003.patch, YARN-5331.004.patch, YARN-5331.005.patch, 
> YARN-5331.006.patch, YARN-5331.007.patch, YARN-5331.008.patch
>
>
> YARN-5326 proposes adding native support for recurring reservations in the 
> YARN ReservationSystem. This JIRA is a sub-task to add a 
> PeriodicRLESparseResourceAllocation. Please refer to the design doc in the 
> parent JIRA for details.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to