[ 
https://issues.apache.org/jira/browse/YARN-7669?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Arun Suresh updated YARN-7669:
------------------------------
    Attachment: YARN-7669-YARN-6592.005.patch

Updating patch based on suggestions:

bq. You mention in the comment of the first enum that it is not retry-able. I 
think it can be retry-able, 
My opinion was - if indeed it were retryable, the algorithm can choose to 
re-place the scheduling request on another node in the same run - in which case 
nobody outside of the algorithm even has to know if it were retried. In 
anycase, I agree with you - it could depend on the algorithm. I removed the 
comment.

bq. So, maybe what we mean but this error is "unsatisfiable user constraints?".
It might be due to an unsatisfiable constratint - but the end outcome was that 
the framworf was not able to place the request on a node - which is what i 
wanted to capture.

bq. Most importantly, will we be using this enum to decide whether we are 
retrying placement or is it just for knowing what went wrong?
So, this enum is used to notify the AM that the SchedulingRequest was rejected 
and why. The AM can choose to retry if it wants. But internally, it will not be 
used to signal a retry. It should be used to tell the AM that even after 
retying, we could not schedule this request.

bq. The Algorithm* classes' names seem too generic. I would prefer to add a 
prefix like Placement or Constraint to all of them.
Done - but IMO, the names seem too long, but it doesnt bother me much.

bq. the RejectionReason in multiple occasions, probably we should give the two 
reasons a more specific name. Like "constraint_violation_on_node" etc
Done.

> [API] Introduce interfaces for placement constraint processing
> --------------------------------------------------------------
>
>                 Key: YARN-7669
>                 URL: https://issues.apache.org/jira/browse/YARN-7669
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Arun Suresh
>            Assignee: Arun Suresh
>         Attachments: YARN-7669-YARN-6592.001.patch, 
> YARN-7669-YARN-6592.002.patch, YARN-7669-YARN-6592.003.patch, 
> YARN-7669-YARN-6592.004.patch, YARN-7669-YARN-6592.005.patch
>
>
> As per discussions in YARN-7612. This JIRA will introduce the generic 
> interfaces which will be implemented in YARN-7612



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to