[ 
https://issues.apache.org/jira/browse/YARN-8018?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16412141#comment-16412141
 ] 

Gour Saha commented on YARN-8018:
---------------------------------

Thanks [~csingh] for the new patch. Please address the checkstyle issues 
identified by jenkins. Few more comments below.
{quote}None of the existing ServiceState are in present continuous including 
FLEX so I called it UPGRADE. I don't have a strong opinion here. I can change 
it to UPGRADING.
{quote}
We are actually going to rename ServiceState.FLEX to FLEXING. See last few 
comments in YARN-7781. So let’s call it UPGRADING. I know what you are 
thinking. A better (non present continuous) word might have been IN_UPGRADE (or 
something even better). But let’s avoid using 2 words for a single enum. Is 
there a one-word non present continuous word we can use? If it makes you feel 
better - before STABLE we had the state RUNNING. We moved from RUNNING to 
STABLE not because we wanted to avoid present continuous words, but because we 
needed a state which meant more than just containers are RUNNING.
h5. ServiceScheduler.java

Add a space after //
{code:java}
  //This encapsulates the <code>app</code> with methods to upgrade the app.
{code}
There are few other places where I found no space after //. Can you scan and 
fix those too.
h5. CoreFileSystem.java
{code:java}
  public Path buildClusterUpgradeDirPath(String clusterName, String version) {
    Preconditions.checkNotNull(clusterName);
    Preconditions.checkNotNull(version);
    return new Path(getBaseApplicationPath(),
        YarnServiceConstants.UPGRADE_DIR + "/" +
            YarnServiceConstants.SERVICES_DIRECTORY + "/" + version);
  }
{code}
How come we are not using the clusterName as a folder in the created Path?

> Yarn service: Add support for initiating service upgrade
> --------------------------------------------------------
>
>                 Key: YARN-8018
>                 URL: https://issues.apache.org/jira/browse/YARN-8018
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Chandni Singh
>            Assignee: Chandni Singh
>            Priority: Major
>         Attachments: YARN-8018.001.patch, YARN-8018.002.patch, 
> YARN-8018.003.patch, YARN-8018.004.patch
>
>
> Add support for initiating service upgrade which includes the following main 
> changes:
>  # Service API to initiate upgrade
>  # Persist service version on hdfs
>  # Start the upgraded version of service



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to