[ 
https://issues.apache.org/jira/browse/YARN-7644?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16644044#comment-16644044
 ] 

Jason Lowe commented on YARN-7644:
----------------------------------

Thanks for updating the patch!

compareAndSetAlreadyLaunched is too explicit -- it essentially exposes the 
AtomicBoolean directly which defeats the point of encapsulation.  Something 
like setLaunched() or markLaunched() which returns false if it was already 
launched would be easier to read and also hide the fact that there's a CAS 
operation on an AtomicBoolean underneath.  In practice the boolean only goes 
one direction, so no need to expose it completely.

EXIT_CODE_FILE_SUFFIX should be package-private instead of protected.  
getContainerPid method also only needs to be package-private.

Nit: ContainerCleanup should cache the pid file path in a local rather than 
always calling the accessor method.

setPidFilePath added but never called.


> NM gets backed up deleting docker containers
> --------------------------------------------
>
>                 Key: YARN-7644
>                 URL: https://issues.apache.org/jira/browse/YARN-7644
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager
>            Reporter: Eric Badger
>            Assignee: Chandni Singh
>            Priority: Major
>              Labels: Docker
>         Attachments: YARN-7644.001.patch, YARN-7644.002.patch, 
> YARN-7644.003.patch
>
>
> We are sending a {{docker stop}} to the docker container with a timeout of 10 
> seconds when we shut down a container. If the container does not stop after 
> 10 seconds then we force kill it. However, the {{docker stop}} command is a 
> blocking call. So in cases where lots of containers don't go down with the 
> initial SIGTERM, we have to wait 10+ seconds for the {{docker stop}} to 
> return. This ties up the ContainerLaunch handler and so these kill events 
> back up. It also appears to be backing up new container launches as well. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to