[ 
https://issues.apache.org/jira/browse/YARN-8918?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16657004#comment-16657004
 ] 

Wangda Tan commented on YARN-8918:
----------------------------------

[~tangzhankun], 

I think the correct logic should be: 
{code:java}
if (resourcesStr.endsWith("]")) {
  resourcesStr = resourcesStr.substring(0, resourcesStr.length() - 1);
}{code}

> [Submarine] Remove redundant method of str.subString(0, str.length())
> ---------------------------------------------------------------------
>
>                 Key: YARN-8918
>                 URL: https://issues.apache.org/jira/browse/YARN-8918
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Zhankun Tang
>            Assignee: Zhankun Tang
>            Priority: Minor
>         Attachments: YARN-8918-trunk.001.patch
>
>
> In CliUtils.java (line 74), there's redundant code block that can be removed:
> {code:java}
> if (resourcesStr.endsWith("]")) {
>  resourcesStr = resourcesStr.substring(0, resourcesStr.length());
> }{code}
> Above if block will execute "resourceStr = resourceStr".



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to