[ https://issues.apache.org/jira/browse/YARN-9269?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Peter Bacsko updated YARN-9269: ------------------------------- Description: Some stuff that we observed: * {{addFpga()}} - we check for duplicate devices, but we don't print any error/warning if there's any. * {{findMatchedFpga()}} should be called {{findMatchingFpga()}}. Also, is this method even needed? We already receive an {{FpgaDevice}} instance in {{updateFpga()}} which I believe is the same that we're looking up. * variable {{IPIDpreference}} is confusing * {{availableFpga}} / {{usedFpgaByRequestor}} are instances of {{LinkedHashMap}}. What's the rationale behind this? Doesn't a simple {{HashMap}} suffice? * {{usedFpgaByRequestor}} should be renamed, naming is a bit unclear * {{allowedFpgas}} should be an immutable list * {{@VisibleForTesting}} methods should be package private * get rid of {{*}} imports was: Some stuff that we observed: * {{addFpga()}} - we check for duplicate devices, but we don't print any error/warning if there's any. * {{findMatchedFpga()}} should be called {{findMatchingFpga()}}. Also, is this method even needed? We already receive an {{FpgaDevice}} instance in {{updateFpga()}} which I believe is the same that we're looking up. * variable {{IPIDpreference}} is confusing * {{availableFpga}} / {{usedFpgaByRequestor}} are instances of {{LinkedHashMap}}. What's the rationale behind this? Doesn't a simple {{HashMap}} suffice? * {{usedFpgaByRequestor}} should be renamed, naming is a bit unclear * {{allowedFpgas}} should be an immutable list * {{@VisibleForTesting}} methods should be package private > Minor cleanup in FpgaResourceAllocator > -------------------------------------- > > Key: YARN-9269 > URL: https://issues.apache.org/jira/browse/YARN-9269 > Project: Hadoop YARN > Issue Type: Sub-task > Reporter: Peter Bacsko > Assignee: Peter Bacsko > Priority: Major > > Some stuff that we observed: > * {{addFpga()}} - we check for duplicate devices, but we don't print any > error/warning if there's any. > * {{findMatchedFpga()}} should be called {{findMatchingFpga()}}. Also, is > this method even needed? We already receive an {{FpgaDevice}} instance in > {{updateFpga()}} which I believe is the same that we're looking up. > * variable {{IPIDpreference}} is confusing > * {{availableFpga}} / {{usedFpgaByRequestor}} are instances of > {{LinkedHashMap}}. What's the rationale behind this? Doesn't a simple > {{HashMap}} suffice? > * {{usedFpgaByRequestor}} should be renamed, naming is a bit unclear > * {{allowedFpgas}} should be an immutable list > * {{@VisibleForTesting}} methods should be package private > * get rid of {{*}} imports -- This message was sent by Atlassian JIRA (v7.6.3#76005) --------------------------------------------------------------------- To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org