[ 
https://issues.apache.org/jira/browse/YARN-9313?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16811553#comment-16811553
 ] 

Weiwei Yang commented on YARN-9313:
-----------------------------------

Hi [~Tao Yang]

Thanks for the patch. It looks almost good to me. Some comments

1) I found {{MULTI_NODES_AGENT_ID}} in \{{ActivitiesManager}} is quite 
confusing, lets rename it to \{{EMPTY_NODE_ID}}. And add some comments for this 
variable, something like: An empty node ID, when we are recording multiple 
nodes assignments in the scheduler, we use this variable as a placeholder in 
the activity records.

2) In \{{ActivityLogger#getRecordingNodeId}}, we can simplify the code to

{code}

return activitiesManager == null ? null : 
activitiesManager.getRecordingNodeId(node);

{code}

3) For UTs in {{TestRMWebServicesSchedulerActivitiesWithMultiNodesEnabled}}, 
please add timeout for test cases, in case they hang for some reason.

Thanks

> Support asynchronized scheduling mode and multi-node lookup mechanism for 
> scheduler activities
> ----------------------------------------------------------------------------------------------
>
>                 Key: YARN-9313
>                 URL: https://issues.apache.org/jira/browse/YARN-9313
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Tao Yang
>            Assignee: Tao Yang
>            Priority: Major
>         Attachments: YARN-9313.001.patch, YARN-9313.002.patch, 
> YARN-9313.003.patch
>
>
> [Design 
> doc|https://docs.google.com/document/d/1pwf-n3BCLW76bGrmNPM4T6pQ3vC4dVMcN2Ud1hq1t2M/edit#heading=h.d2ru7sigsi7j]



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to