[ 
https://issues.apache.org/jira/browse/YARN-7621?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16895048#comment-16895048
 ] 

zhoukang edited comment on YARN-7621 at 7/29/19 8:27 AM:
---------------------------------------------------------

NIT: Since in our cluster there will exist 'root.a.a1' and 'root.b.a1'.
So we also support initialize queues with full path name.
{code:java}
@Override
  public void addQueue(String queueName, CSQueue queue) {
    queueName = queue.getQueuePath();
    this.queues.put(queueName, queue);
  }
{code}
Do you think this feature should be supported in community version 
[~cheersyang][~Tao Yang]


was (Author: cane):
NIT: Since in our cluster there will exist 'root.a.a1' and 'root.b.a1'.
So we also supported initialize queues with full path name.
{code:java}
@Override
  public void addQueue(String queueName, CSQueue queue) {
    queueName = queue.getQueuePath();
    this.queues.put(queueName, queue);
  }
{code}
Do you think this feature should be supported in community version 
[~cheersyang][~Tao Yang]

> Support submitting apps with queue path for CapacityScheduler
> -------------------------------------------------------------
>
>                 Key: YARN-7621
>                 URL: https://issues.apache.org/jira/browse/YARN-7621
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: capacityscheduler
>            Reporter: Tao Yang
>            Priority: Major
>              Labels: fs2cs
>         Attachments: YARN-7621.001.patch, YARN-7621.002.patch
>
>
> Currently there is a difference of queue definition in 
> ApplicationSubmissionContext between CapacityScheduler and FairScheduler. 
> FairScheduler needs queue path but CapacityScheduler needs queue name. There 
> is no doubt of the correction of queue definition for CapacityScheduler 
> because it does not allow duplicate leaf queue names, but it's hard to switch 
> between FairScheduler and CapacityScheduler. I propose to support submitting 
> apps with queue path for CapacityScheduler to make the interface clearer and 
> scheduler switch smoothly.



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to