[ 
https://issues.apache.org/jira/browse/YARN-10189?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Benjamin Teke updated YARN-10189:
---------------------------------
    Description: 
Some things can be improved:
 * there is an unnecessary import
 * throws Exception declaration can be removed from 
LeveldbRMStateStore.initInternal method 
 * key variable is redundant in LeveldbRMStateStore.dbStoreVersion
 * try can use automatic Resource management in 
LeveldbRMStateStore.loadReservationState/loadRMDTSecretManagerKeys/loadRMDTSecretManagerTokens/loadRMApps/...
 etc
 * there were some methods which were copied to LeveldbConfigurationStore (ie: 
openDatabase, storeVersion, loadVersion, CompactionTimerClass nested class), a 
helper class could be created to reduce the duplicated code
 * Any other cleanup

  was:
Many things can be improved:
* Field compactionTimer could be a local variable
* Field versiondb should be camelcase
* initDatabase is a very long method: Initialize db / versionDb should be in 
separate methods, split this method into smaller chunks
* Remove TODOs
* Remove duplicated code block in LeveldbConfigurationStore.CompactionTimerTask
* Any other cleanup


> Code cleanup in LeveldbRMStateStore
> -----------------------------------
>
>                 Key: YARN-10189
>                 URL: https://issues.apache.org/jira/browse/YARN-10189
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Benjamin Teke
>            Assignee: Benjamin Teke
>            Priority: Minor
>
> Some things can be improved:
>  * there is an unnecessary import
>  * throws Exception declaration can be removed from 
> LeveldbRMStateStore.initInternal method 
>  * key variable is redundant in LeveldbRMStateStore.dbStoreVersion
>  * try can use automatic Resource management in 
> LeveldbRMStateStore.loadReservationState/loadRMDTSecretManagerKeys/loadRMDTSecretManagerTokens/loadRMApps/...
>  etc
>  * there were some methods which were copied to LeveldbConfigurationStore 
> (ie: openDatabase, storeVersion, loadVersion, CompactionTimerClass nested 
> class), a helper class could be created to reduce the duplicated code
>  * Any other cleanup



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to