[ 
https://issues.apache.org/jira/browse/YARN-584?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13816444#comment-13816444
 ] 

Sandy Ryza commented on YARN-584:
---------------------------------

Thanks the picking this up, Harshit.  It seems like it would be difficult to 
write unit tests for this, so I'm ok with not including them.  Can you mention 
the steps you've taken to manually test the patch?

As the added code is very similar for both schedulers, are we able to share it 
in a central location? We could create a SchedulerPageUtil.

Can we change the names of addRemoveQueueToQuery and the other function names 
to make it clear that they're related to expand / unexpand?

A few stylistic comments:
* Lines should be broken up so that they fit within close to 80 characters.
* There should be a space between "if" and "for" and the corresponding open 
parentheses.
* There should be spaces between the operators and operands in conditions, e.g 
(a == b), not (a==b)
* There should be spaces after the semicolons in for loops.
* There should be spaces in between "else" and the surrounding curly braces.
* Closing curly braces should line up vertically with the beginning of the 
statement like so:
{code}
if (condition) {
  dostuff;
}
not
if (condition) {
  dostuff; }
{code}

> In fair scheduler web UI, queues unexpand on refresh
> ----------------------------------------------------
>
>                 Key: YARN-584
>                 URL: https://issues.apache.org/jira/browse/YARN-584
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: scheduler
>    Affects Versions: 2.0.3-alpha
>            Reporter: Sandy Ryza
>              Labels: newbie
>         Attachments: YARN-584-branch-2.2.0.patch
>
>
> In the fair scheduler web UI, you can expand queue information.  Refreshing 
> the page causes the expansions to go away, which is annoying for someone who 
> wants to monitor the scheduler page and needs to reopen all the queues they 
> care about each time.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Reply via email to