[ 
https://issues.apache.org/jira/browse/YARN-10319?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17143416#comment-17143416
 ] 

Tao Yang commented on YARN-10319:
---------------------------------

Thanks [~prabhujoseph] for this improvement.
I agree that it may be helpful for single-node lookup mechanism, with which 
users can get all-nodes activities in multiple scheduling cycles at once for 
better debugging. 
Some comments about the patch:
* Is it better to rename "bulkactivities" (REST API name) to "bulk-activities"? 
* SchedulerActivitiesInfo is similar to ActivitiesInfo which also means 
scheduler activities info, can we rename it to BulkActivitiesInfo?
* To keep consistence, we can also rename RMWebServices#getLastNActivities to 
RMWebServices#getBulkActivities.
* ActivitiesManager#recordCount can be affected by both activities and 
bulk-activities REST APIs, we can use `recordCount.compareAndSet(0, 1)` instead 
of `recordCount.set(1)` to avoid getting unexpected number of bulk-activities, 
right?
* The fetching approaches of activities and bulk-activities REST API are 
different (asynchronous or synchronous), I think we should elaborate this in 
the document.

> Record Last N Scheduler Activities from ActivitiesManager
> ---------------------------------------------------------
>
>                 Key: YARN-10319
>                 URL: https://issues.apache.org/jira/browse/YARN-10319
>             Project: Hadoop YARN
>          Issue Type: Improvement
>    Affects Versions: 3.3.0
>            Reporter: Prabhu Joseph
>            Assignee: Prabhu Joseph
>            Priority: Major
>              Labels: activitiesmanager
>         Attachments: Screen Shot 2020-06-18 at 1.26.31 PM.png, 
> YARN-10319-001-WIP.patch, YARN-10319-002.patch, YARN-10319-003.patch
>
>
> ActivitiesManager records a call flow for a given nodeId or a last call flow. 
> This is useful when debugging the issue live where the user queries with 
> right nodeId. But capturing last N scheduler activities during the issue 
> period can help to debug the issue offline.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to