[ 
https://issues.apache.org/jira/browse/YARN-9879?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17256546#comment-17256546
 ] 

Nie Gus commented on YARN-9879:
-------------------------------

Hi [~shuzirra] ,

really appreciate this patch, we are using this patch in our branch, it worked 
quite well, but still we found there are lots of place still using 
"getQueueName" , and we also see "fullPathQueueNamingPolicy" could change the 
output of getQueueName to queuePath directly, but the code is set it to final 
false. Is that for future work ? or something still block the directly 
replacement between queueName and queuePath, so currently we set it false, 
should we consider to  change it into conf ?

 

<<<<<<<<<<<<<<<

private final boolean fullPathQueueNamingPolicy = false;

@Override
public String getQueueName() {
 if (fullPathQueueNamingPolicy) {
 return queuePath;
 }
 return queueName;
}

 

 

> Allow multiple leaf queues with the same name in CapacityScheduler
> ------------------------------------------------------------------
>
>                 Key: YARN-9879
>                 URL: https://issues.apache.org/jira/browse/YARN-9879
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Gergely Pollak
>            Assignee: Gergely Pollak
>            Priority: Major
>              Labels: fs2cs
>             Fix For: 3.3.0
>
>         Attachments: CSQueue.getQueueUsage.txt, DesignDoc_v1.pdf, 
> YARN-9879.014.patch, YARN-9879.015.patch, YARN-9879.015.patch, 
> YARN-9879.POC001.patch, YARN-9879.POC002.patch, YARN-9879.POC003.patch, 
> YARN-9879.POC004.patch, YARN-9879.POC005.patch, YARN-9879.POC006.patch, 
> YARN-9879.POC007.patch, YARN-9879.POC008.patch, YARN-9879.POC009.patch, 
> YARN-9879.POC010.patch, YARN-9879.POC011.patch, YARN-9879.POC012.patch, 
> YARN-9879.POC013.patch
>
>
> Currently the leaf queue's name must be unique regardless of its position in 
> the queue hierarchy. 
> Design doc and first proposal is being made, I'll attach it as soon as it's 
> done.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to