[ 
https://issues.apache.org/jira/browse/YARN-1504?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13885942#comment-13885942
 ] 

Karthik Kambatla commented on YARN-1504:
----------------------------------------

Comments:
# AbstractYarnScheduler: The exception message should specify the current 
scheduler being used, not FairScheduler.
{code}
  @Override
  public String moveApplication(ApplicationId appId, String newQueue)
      throws YarnException {
    throw new YarnException(
        "Fair Scheduler does not support moving apps between queues");
  }
{code}
# TestClientRMService: can we add more tests to cover all the error cases being 
checked for in ClientRMService#move*()
# Shouldn't need a new RMAppAttemptEventType for MOVE? 
# RMAppMoveTransition: Using futures, it is easy to regress and not set the 
Exception or value of the future. Can we add comments (may be javadoc style) 
describing the contract honored by RMAppMoveTransition? Also, we should add 
unit tests for RMAppMoveTransition to avoid regressions in the future - verify 
either the value or the exception is set.
# Nit: Not a fan of the field name - RMAppEvent#resultFuture. Any better names? 
How about just result? 
# Nit: Would drop the RMAppState changes (comments) - don't seem to add much. 

> RM changes for moving apps between queues
> -----------------------------------------
>
>                 Key: YARN-1504
>                 URL: https://issues.apache.org/jira/browse/YARN-1504
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>    Affects Versions: 2.2.0
>            Reporter: Sandy Ryza
>            Assignee: Sandy Ryza
>         Attachments: YARN-1504.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Reply via email to