[ 
https://issues.apache.org/jira/browse/YARN-1525?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13899668#comment-13899668
 ] 

Karthik Kambatla commented on YARN-1525:
----------------------------------------

Thanks Cindy. Thanks for your patience through the reviews.

Functionally, the patch looks good. Some comments on the cosmetics:
* The following indentation needs to be fixed:
{code}
  @Override
    public boolean isStandbyMode() {
{code}
* Setting the redirect path in WebApp#isStandbyMode() is a little misleading. 
Can we leave isStandbyMode() to only report whether the RM is in standby mode, 
and may be getRedirectPath() can take care of constructing the path if 
required. 
* Rename RMWebApp#findRedirectPath to buildRedirectPath?
* Couple of lines longer than 80 chars
{code}
    if (webApp.isStandbyMode() && !uri.equals("/" + webApp.name() + 
"/cluster")) {
      String redirectPath = webApp.getRedirectPath();
      if (redirectPath != null && !redirectPath.isEmpty()) {
        String redirectMsg =
            "This is a standby resource manager, redirecting to the current 
active one: "
                + redirectPath;
{code}
* TestRMFailover#testRMWebAppFailover
** Rename to testRMWebAppRedirect to capture the behavior better
** If it is not too much trouble, given the test doesn't do any failover, we 
should probably move it to TestRMHA? 
* Let us add Private-Unstable annotations to RMHAUtils so we can move the 
methods or even remove this class if we don't see the code being reused.

I ll be glad to test the updated patch out on a secure cluster for verification.

> Web UI should redirect to active RM when HA is enabled.
> -------------------------------------------------------
>
>                 Key: YARN-1525
>                 URL: https://issues.apache.org/jira/browse/YARN-1525
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Xuan Gong
>            Assignee: Cindy Li
>         Attachments: YARN1525.patch, YARN1525.patch.v1, YARN1525.patch.v2, 
> YARN1525.patch.v3, YARN1525.v7.patch, YARN1525.v7.patch, YARN1525.v8.patch, 
> YARN1525.v9.patch
>
>
> When failover happens, web UI should redirect to the current active rm.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Reply via email to