[ 
https://issues.apache.org/jira/browse/YARN-2932?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14274448#comment-14274448
 ] 

Wangda Tan commented on YARN-2932:
----------------------------------

1. Rename isQueuePreemptable to getQueuePreemptable for getter/setter 
consistentency in CapacitySchedulerConfiguration

2. Should consider queue reinitialize when queue preemptable in configuration 
changes (See {{TestQueueParsing}}). And it's best to add a test for verify that.

3. It's better to remove the defaultVal parameter in 
CapacitySchedulerConfiguration.isPreemptable:
{code}
public boolean isQueuePreemptable(String queue, boolean defaultVal) 
{code}
And the default_value should be placed in CapacitySchedulerConfiguration, like 
other queue configuration options.

I understand what you trying to do is moving some logic from queue to 
CapacitySchedulerConfiguration, but I still think it's better to keep the 
CapacitySchedulerConfiguration simply gets some values from configuration file.

Thanks,

> Add entry for preemption setting to queue status screen and startup/refresh 
> logging
> -----------------------------------------------------------------------------------
>
>                 Key: YARN-2932
>                 URL: https://issues.apache.org/jira/browse/YARN-2932
>             Project: Hadoop YARN
>          Issue Type: Bug
>    Affects Versions: 3.0.0, 2.7.0
>            Reporter: Eric Payne
>            Assignee: Eric Payne
>         Attachments: YARN-2932.v1.txt, YARN-2932.v2.txt, YARN-2932.v3.txt
>
>
> YARN-2056 enables the ability to turn preemption on or off on a per-queue 
> level. This JIRA will provide the preemption status for each queue in the 
> {{HOST:8088/cluster/scheduler}} UI and in the RM log during startup/queue 
> refresh.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to